Karl`s PC Help Forums Last active: Never
Not logged in [Login ]
Go To Bottom

In memory of Karl Davis, founder of this board, who made his final journey 12th June 2007

Printable Version | Subscribe | Add to Favourites   Post new thread Poll:
Author: Subject: Unable To Delete A Registry Entry
Custom User Title

Posts: 2096
Registered: 21-4-2007
Theme: KF Blue (Default)
Member Is Offline

Mood: No Mood

[*] Post 489659 posted on 19-9-2014 at 15:32 Reply With Quote
Unable To Delete A Registry Entry


I apparently, agreed, during the install process for a piece of free software to add (bundled) a search engine called "Astromenda" to my IE browser.

I was able to find this PUP ("Potentially Unwanted Program" as defined in malware sites) as an installed program in my Windows Add/Remove area, but that process did not, by any means, completely remove this 'gear', i. e., it kept showing up in IE (my default browser).

So I resorted to manually deleting every entry for Astromenda that I could find in Windows Registry (which worked without any system issues), with the exception of two entries (image file for one of them attached).

These two renegades, and how to get rid of them, are the purpose of this post.

Two entries, when I attempted to delete them (multiple times, including after warm and cold reboots), gave me a "unable to delete all specified values" pop up window message. A Google search did not give me any info as to what a "job" file extension is/does when it appears in registry, never mind how to get rid of it, to include why I got the pop up window during my attempt to delete it.

Anyone know why I can't delete this entry?

JackInCT has attached this image.
Click the image to enlarge it:

Click Image To Enlarge
View User's Profile View All Posts By User
Anything you like


Posts: 7886
Registered: 23-7-2002
Theme: Coffee
Member Is Offline

Mood: Fintlewoodlewix.

[*] Post 489662 posted on 19-9-2014 at 21:10 Reply With Quote

Have you tried deleting the key in "Safe Mode"?

If that doesn't work, you could try psexec of PSTools (create a system restore point beforehand).

Download PS Tools:


Unzip PSTools and place PsExec.exe in the C:\Windows\System32 folder.

Then do the following:

Start > type cmd.exe then right-click cmd.exe and select "Run as administrator"

Then, at the command prompt, type the following and press "Enter":

psexec -s -i regedit.exe

Locate and delete the key.

Close regedit and cmd.exe

With psexec you should be able to delete just about any registry key. So, take care, when using it.
View User's Profile View All Posts By User
Undercover MOD


Posts: 32767
Registered: 19-11-2004
Location: Riverton, South Australia
Theme: Windows XP Silver
Member Is Offline

Mood: Gone crazy, Back soo

[*] Post 489670 posted on 20-9-2014 at 02:47 Reply With Quote

I agree with Katzy, the safe mode route should work. As for the other tool, if she recommends it, then go for it. It's not one that I've had experience with.
View User's Profile View All Posts By User
Post new thread Poll:

Guest Notice
You are a guest, as a guest you can only see a maximum of 3 posts per thread.

If you want to see the rest, please click here to register.