Karl`s PC Help Forums

FYI: Experiments With My Laptop Without Any Internal HD Installed
JackInCT - 18-12-2017 at 17:52

This series of events began last week when I attempted to install the Windows Updates for Dec. Nov's updates were uneventful, but upon bootup [amonth later with no use of this machine in the interval], and the attempt to launch Dec Updates, I got a dialog Window message that "Windows Updates Service Not Running" [NOT ever seen that before]. I then spent a considerable amount of time via Google hits trying to resolve the issue, to include a final attempt via a System Restore back to Oct. No Joy!

As we ALL know, the vast majority of updates are all related to the infinite number of the security shortcomings of Windows OSs. This particular machine is a 7+ yrs old laptop running Win 7, Home Edition. It is heavy and slow, and it hasn't been out in the field since 2012; otherwise it is a perfectly acceptable machine.

I found myself unwilling to do a reinstall of the OS [I have the original OEM install CD-that's how old this machine is]; I also guessed that making an archival ISO file redo would contain the same error(s). I toyed with the idea of continuing to use this machine AS IS, i. e., no further security updates, and simply never ever using the web for anything like online purchases (& email, etc.,) that a hacker could succeed in penetrating due to an unclosed hole. That option remains available, until, and if, I EVER find myself in the mood for an OS reinstall.

Over the past several months I have purchased about a dozen used SATA HDs from my go to computer mechanic at a considerable saving over a new one. In turn, I have installed a different Linux distro on each one [the Fun & Games approach to Inner Peace].

In turn, I took the internal HD out of my laptop, i. e., it's bare of HDs, and proceeded to do the following: I have an external SATA HD with its own power supply (the availability of the external power supply may be a critical resource in what I'm about to report on). I then connected this external HD via a USB cable to the laptop; and I popped in, chosen at random, one of my Linux distros. I then turned on the laptop, and wonder of wonders, it booted right up to desktop (no going into BIOS/whatever to select the HD). That's worked perfectly for 3 different distros with all the built in goodies on my laptop like WiFi, Bluetooth, etc.,.

I also tried this with my still servicable Win 7 OS HD--No Joy. It did boot up, sort of, to a warning screen that there were problems, and it did give me a choice of using Win Recovery, & Win Restore neither of which worked [the Win 7 splash screen comes up upon bootup for a few secondsbefore I got this warning screen]. This result is NOT unexpected for those that choose to mess with hardware.

Since I love these kinds of challenges (Yeah Right), does anyone have any ideas as to how I could "fool" the laptop into booting up the Win 7 OS from an external HD [OR perhaps some other "method" of doing so]?

LSemmens - 18-12-2017 at 23:58

Since you can still get into Windoze

open a command prompt with administrator rights
run the command "sfc /scannow"

that should rectify any damaged files.

If you need more specifics, get back to me.

JackInCT - 19-12-2017 at 01:00

Roger Wilco--worth a shot re you can't possibly ever learn enough about Windows even if you're a home user, AND certainly a much better option than a complete reinstall. I do wish, as a home user, I could figure out how this could have happened, but's that's not to be. As best as I can recall, Nov's updates required a reboot, but there would have been no reason for me to go back and double check updates, and there were no follow up update available icon in Sys Tray. I do typically with this machine, upon conclusion of the Win Updates, ALSO update all the software installs, one by one, and there were likely (I don't recall) some of those. For future reference, posters who find themselves in such a situation, should question whether the antivirus software had something to do with all of this, although that gear did not give me any warning about "blocking/warning" anything.

LSemmens - 19-12-2017 at 01:36

Out of curiosity which AV are you running? I've had no problems on any of my machines.

JackInCT - 19-12-2017 at 02:14

Originally posted by LSemmens
Out of curiosity which AV are you running? I've had no problems on any of my machines.

Free Avast--a typical Google search includes hits that state that the inability to do a download should include a looksee as to whether the antivirus is the culprit, TO INCLUDE, turning if OFF, to see IF then the download can be done--obviously that entails risks.

LSemmens - 19-12-2017 at 09:34

I've no experience with Avast, so cannot offer any useful suggestions, other than to turn it off and try again.

Katzy - 19-12-2017 at 10:20

If Windoze hasn't attemted to install W10, without your say so, you can boot from the W7 disk and do a repair, can you not? As a last resort

JackInCT - 19-12-2017 at 15:31

Originally posted by Katzy
If Windoze hasn't attemted to install W10, without your say so, you can boot from the W7 disk and do a repair, can you not? As a last resort

That's a pretty good idea as that's something that I have never attempted, and should learn as 4 of my 5 machines run Win 7--and you never know.

JackInCT - 27-12-2017 at 01:40

Originally posted by JackInCT
This series of events began last week when I attempted to install the Windows Updates for Dec on my laptop. Nov's updates were uneventful, but upon bootup [a month later with no use of this machine in the interval], the attempt to launch Dec Updates resulted in a dialog Window message that"Windows Updates Service Not Running" [NOT ever seen that before]...

The NeverEnding Tale AKA The Saga Ends, AND We All Live Happily (relatively speaking) Ever After?!?!

When I finally decided to put the time into my also 'dormant' secondary desktop PC to download Dec's Win Updates, and you really can't blame it for feeling ignored, Lo & Behold, I got the very same message re 'Update Service Not Running' as I did on my laptop [BUT did not get on myprimary PC].

I once again went out to Google.

As I have noted previously on this board, Win has a finite set of error messages for an infinite set of problems. That may apply to this situation, i. e., the error message is misleading/off the mark.

There are a large number of hits for this issue, and it's been around on various OSs for a long time.

I dutifully began with hit #1, and worked my way down. Many of the hits were of the 'try this, or that', from the Command Line--none of them worked. Then I came upon a hit that offered no explanation where its author came upon his solution, and it stated very simply, (1) Turn Windows Update Off (via Control Panel), (2) Reboot, (3) Return to Control Panel and select "Automatic Updates". Well, as soon as I selected Auto Update, the Update Service error disappeared and Win began searching for Updates; everything was back to normal.

I have no idea what the origin of this error was, OR why the solution worked (by the way I did try "sfc /scannow", as well as an attempt with my antivirus turned off [with reboots after each]; no joy). And I cannot explain why all 3 machines did not have the same error; nor can I ascertain, one way or another, if there was some kind of a driver/software/whatever conflict; I suspect the solution, since it worked, had nothing to do with a conflict [by the way, none of the failed attempts involved going into Registry or any radical alterations to the systems].

I also suspect that since there was a good amount of time in the intervals between attempts at Updates, IF MS had messed up someway, they would have corrected the problem by the 3rd update try.