Karl`s PC Help Forums

NIC Assistance Please
LSemmens - 29-12-2007 at 08:27

I'm fixing a friends 'puter, all HWare seems ok despite low spec (256Mb Shared Ram, 80Gb HDD, Via C3 800MHz CPU, 6A6LUG0JC MOBO) so software is most likely the issue.
XPSP2 with all updates.

As they are on dial up, I thought I'd plug the box into my DLink DSL-G604T DSL Router and download updates for the various security packages. This is where I run into strife. Every other PC I've plugged into the router is automatically detected, Not this one! I've tried to repair the network connection, turned off the Firewall (you don't want to know which one!) Flushed DNS, I even tried a static IP. I've even The system only reports limited connectivity! I've swapped cables and ports on the router and they all work on my main box, just not this one! Ipconfig /renew just times out! What am I missing?

Topcat - 29-12-2007 at 08:58

You don't say whether your have an on-board Nic or a PCI plugin, but have you also activated the NIC through the BIOS and de-activated the Modem.
Also in Internet Options there are options for dialing out they need to be changed.


LSemmens - 29-12-2007 at 10:14

On board everything, except modem only one PCI Slot, so can't even install another NIC. This was a budget machine whose intent was never to be upgraded. BIOS has NIC activated. As for the other changes that you've suggested, No other machine that I've used has required that drastic action. My main machine is set up with a dial up connection as a fallback, as is my laptop and just about every other PC in my house.

The MOBO was reported incorrectly by Everest, it's actually a Gigabyte GA-PCV2. It is very compact with room for one stick of RAM, One PCI card, 4 IDE devices and nothing else.

Katzy - 29-12-2007 at 10:44

Tried ipconfig /release and ipconfig /renew?

Tried repairing the TCP/IP and/or windsock?


LSemmens - 29-12-2007 at 10:52

All of those!

Am downloading xptcprep as I type.

Topcat - 29-12-2007 at 15:18

Originally posted by LSemmens
On board everything, except modem only one PCI Slot, so can't even install another NIC.

You could remove the Modem and plug in a PCI Nic, a temporary option, but if it works it might help you solve the problem.

Also if it works OK you could opt for an external Modem.


LSemmens - 30-12-2007 at 11:10

That was to be my next option, I was hoping for an easier fix as the box was supposed to be a quick fix and out the door, some idiot once said "Life wasn't meant to be easy!"