Karl`s PC Help Forums

mmc.exe is not a valid win32 appli
KOUROSH - 22-12-2007 at 16:40

i went to control, system /hardware and when i clicked on it it said mmc.exe is not a valid window application and it won't open. how this has happened???? do i have to do win repair to get it fixed???

also bios i wonder if you have the experty?? on my bios when i enter there is this
LOAD OPTOMIZED DEAFULTS???? what does it do ?? do i have to type y or N what would be the difference.


system BIOC cachable is this suppose to be able or disabled?? what would be the difference

and finally what do i have to do in bios so when the floppy disk in the floppy drive the window will ignore and stats up rather than telling me it can not start

your help will be much appreciated

Katzy - 22-12-2007 at 19:22

You could have a virus.

However, Click "Start" and "Run".

In the emulated DOS window that opens, type "sfc /scannow" and hit "Enter". Let it do it's thing and you might be OK.

As for your BIOS settings, have a look here:


KOUROSH - 22-12-2007 at 20:20

Katzy many thanks when i type scannow it says window can not find scannow????????????????

with regard to bios that is brilient it explain to a large extent, i wonder if you know what changes i have to make it so when floppy is in window starts??????????many thanks

LSemmens - 23-12-2007 at 13:31

You must type everything exactly as Katzy has explained. i.e. type everything in bold type sfc /scannow

Basically the command is System File Checker, and you are telling it to perform an immediate scan.

To Enter mmc.exe (Microsoft Management Console), try clicking on "Admin Tools" in Control Panel.

KOUROSH - 23-12-2007 at 19:38

LSemmens, many thanks, i was typing the right word, there is a space between C and the right stroke, now that i type the correct word on the first occasion a small window appeared asking me insert the window xp so it can check window files after 40 minutes i it finished and the window disappeared so i went for a restart to make sure everything is saved but the problem is still there but when i type scannow a window appears for fraction of seconds and then disappears ??? you have the experience what is suppose to happen when i type sfc /scannow. many thanks

Daz - 24-12-2007 at 02:37

This M$ KB article explains SFC Kourosh...

KOUROSH - 24-12-2007 at 11:02

Daz many thanks, i have tried it twice put the window cd in and it checked the window files but when it finished i had a look at control/ system/ hardware/ device manager but it was still as bad as before so checking the files had not fixed it. i restarted the pc but window started but the screen went black i waited about 10 minutes hoping it can find its way back and starts !!! it did not i had to restart go for safe mode then i went for a restore and that is how i managed to get the window started i did this twice. clearly when it checks window somehow it does not repair the window properly.

link below shows quite a lot of other people have suffered the same problem

http://www.google.co.uk/search?q=mmc.exe+is+not+a+valid+win32+appli&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:e n-US:official&client=firefox-a

KOUROSH - 24-12-2007 at 13:27

i went back for two weeks Restore that has solved the problem . many thanks to everyone

LSemmens - 24-12-2007 at 13:52

What were you hoping to achieve by using MMC?

Some of the issues with mmc and other files may be actually virus related. I can't remember Kourosh, what security are you running, is it up to date, and what scan results do the return?

Katzy - 24-12-2007 at 16:18

When you'd finished with the CD, you should have gone to WIndows update, because a lot of the system files would've been updated.

You seem sorted, now, though, so all's good.

KOUROSH - 24-12-2007 at 17:49

Katzy and LSemmens many thanks, i think somehow it got corrupted it could not be virus because i run virus check every day.
also when LSemmens mentioned adminstrative tool and i tried it i manged to get to device manger to check for ethernet controller with no problem. when i went to google i saw guile a lot of others who had suffered the same fate why it gets corrupted and how no one has come up with answer.

Merry Xmass to you all