Karl`s PC Help Forums Last active: Never
Not logged in [Login ]
Go To Bottom

In memory of Karl Davis, founder of this board, who made his final journey 12th June 2007

Post Reply
Who Can Post? All users can post new topics and all users can reply.
Username   Need to register?
Password:   Forgot password?
Subject: (optional)
Icon: [*]
Formatting Mode:
Normal
Advanced
Help

Insert Bold text Insert Italicised text Insert Underlined text Insert Centered text Insert a Hyperlink Insert E-mail Hyperlink Insert an Image Insert Code Formatted text Insert Quoted text Insert List
Message:
HTML is Off
Smilies are On
BB Code is On
[img] Code is On
:) :( :D ;)
:cool: :o shocked_yellow :P
confused2 smokin: waveysmiley waggyfinger
brshteeth nananana lips_sealed kewl_glasses
Show All Smilies

Disable Smilies?
Use signature?
Turn BBCode off?
Receive email on reply?
The file size of the attachment must be under 200K.
Do not preview if you have attached an image.
Attachment:
    

Topic Review
LSemmens

[*] posted on 12-4-2008 at 14:46
Quote:
Originally posted by dpursell
I am trying to write a batch file to backup my documents folder. I am using xp pro. below are the steps i am using:
1. start>run>cmd
copy con backup.bat
x copy *.* e:\weekly backup /e /v /y
enter
ctrl z
enter

I then try to run the file and receive the following message:
invalid number of parameters

what am i doing wrong? E is my external usb harddrive.


Try this:
You'll note that I've added a line that changes to the "my documents directory, assuming that you are only one level up and in the "drive:\Documents and settings\username\" directory
I've also removed the space between x and copy, the command is "xcopy" and I've also contracted you destination folder to just "backup" DOS can get confused with long filenames and this is just a "safer" method.
Quote:

1. start>run>cmd
copy con backup.bat
cd my documents
xcopy *.* e:\backup /e /v /y
enter
ctrl z

dpursell

[*] posted on 12-4-2008 at 11:41
I was typing xcopy. when i changed my backup folder to backup instead of weekly backup it worked just fine.
Katzy

[*] posted on 12-4-2008 at 09:17
For one thing, it's "xcopy", not "x copy"...

You may be getting the error, coz it's taking it as "copy".
dpursell

[*] posted on 12-4-2008 at 00:16
I am trying to write a batch file to backup my documents folder. I am using xp pro. below are the steps i am using:
1. start>run>cmd
copy con backup.bat
x copy *.* e:\weekly backup /e /v /y
enter
ctrl z
enter

I then try to run the file and receive the following message:
invalid number of parameters

what am i doing wrong? E is my external usb harddrive.